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Topic Overview

BCA ACADEMY

Day 4

Day 1 Day 2 Day 3
AM BIM Fundamentals | BIM e-Submission (Assignment — 3D part
& Revit Interface Guidelines & finish)
Template Overview
Starting a BIM Basic 3D modeling :
project: Project staircase, railing,
template, Insert roof, ceiling
files, Project base
point, Grids &
Levels, Create
views
PM Site & Mass Family editor
Modelling interface & simple

Basic 3D modeling
: Wall, floor, ramp,
doors & windows

(Assignment — 3D
part)

family creation

Basic 2D elements:
rooms, areq,
annotation,
dimension, tags,
schedule, sheets,
titleblock, exporting
files.

(Assignment —
2D
Documentation,
Family)
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DAY 2

Basic 3D modeling : staircase, railing, roof,
ceiling




Keyboard Shortcuts

Applications Menu View>Graphics Modify>View
Ctri+N New VG/VV | Visibility/Graphics EH Hide in View: Hide Elements
Ctri+0 Open TL Thin Lines EOD Override Graphics in View
Crri+S Save RR Render w Linework
Ctri+P Print RD Render in Cloud VH Hide in View: Hide Category
Architecture>Build RG Render Gallery Zoom
WA Wall View>Windows ZA Zoom All to Fit
DR Door wcC Cascade Windows ZEfZFjZX | Zoom to Fit
WN Window WT Tile Windows 20/2v Zoom Out{2x)
™M Place a Component PP Properties ZrPjzC Previous Pan/Zoom
CL Column KS Keyboard Shortcuts ZR/ZZ Zoom in Region
Architecture>Model Manage>Settings Zs Zoom Sheet Size
GP Create Group UN Project Units Snaps
4] Model Line SU Sun and Shadow Settings PC Snap to Point Clouds
Architecture>Room & Area Modify>Clipboard SC Centres
RM Room MA ] Match Type Properties SE Endpoints
RT Tag Room Modify>Geometry Sl Intersections
Architecture>Datum e Copt fppuNOtCiRE L | SM [ Midpoints
18 Level PT Paint SN Nearest
GR Grid SO Snap Off
Architecture>Work Plane SF Split Face SP Perpendicular
RP l Reference Plane Modify>Modify SQ Quadrants
Annotate>Dimension AL Align SR Snap to Remote Objects
DI Aligned Dimension AR Array ST Tangents
EL Spot Elevation Co/CC | Copy sSw Work Plane Grid
Annotate>Detail cs Create Similar SX Points
DL | DetsilLine DE | Delete sz Close
AnnotatesText DM | Mirror - Draw Axis View Control Bar B "_d
X Text MM Mirror - Pick Axis CX Reveal Constraints
FR Find/Replace MV Move GD Graphic Display Options
Annotate>Tag OF Offset HL Hidden Line
TG l Tag by Category PN Pin RY Ray Trace
Collaborate>Synchronize RE Scale SD Shaded
RL/RW Reload Latest RO Rotate WF Wireframe
ER Editing Requests SL Split Element Function Keys
TR Trim/Extend to Corner F1 Displays Revit Help
UP Unpin F7 Spelling
F8 Navigation Wheel
F!.O‘AR Keytips
Flip or rotate 90 de s
prahey se'rected elements i
Tsb Cyc_les through snaps or
chain of elements

r
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You may customize your own keyboard
shortcuts in Revit. The window is available at
View tab > Windows panel > User Interface >
Keyboard Shortcuts or simply type KS.

L. e T T T e e e e T e

R Keyboard Shortcuts ? X
Search: Type a command name Do
Filter: All v
Assignments:
Command Shortcuts Paths L=
Modify MD Create=Select; Insert=Select; Ann...
Select links Create=Select; Insert=Select; Ann...
Select underlay elements Create>Select; Insert=Select; Ann...
Select pinned elements Create=Select; Insert>Select; Ann...
Select elements by face Create>Select; Insert>Select; Ann...
Drag elements on select... Create>Select; Insert=Select; Ann...
Type Properties Create>Properties; Modify>Prope...
Properties PP Create=Properties; View=Windo...
Ctrl+1
VP
Family Category and Par... Create>Properties; Modify=Prope...
< >
Press new keys: £ 7 Assign == Remove
Import... ‘ ‘ Export... OK ‘ ‘ Cancel
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Stack Walli

Architecture

[GPE @ | FEEEEE BoS AL W& K2~ fuiv .. @o-
’ B[y Vertical I7 Ref Plane
Modify] Wall oor Window Component  Column Roof Ceiling Floor |Curtain|Curtain Mullion | Railing Ramp Stair  Model Model Model | Room Room Tag By Shaft If Eﬁ Grid Set 7
T v v v T System| Grid v v Text Line Group Separator Room ~ [ Tag Area ~ Face J Dormer [ER viewer
Select Build Circulation | Model | Room & Area « | Opening | Datum | Work Plane |
H Type P rti X
Architecture Tab > Wall ype Properties

1 PTOP'E'I'ﬁES A ‘ X 2 Family: System Family: Stacked Wall w Load...

1 I
Si‘aCked Wq" : G Wq" made U Of | Type: Typ Cladding w Plinth w Footing LY Duplicate...
l e | ; Stacked Wall
1
I
1

| different “Wall Types" stacked vertically TNCNGYPg W Plinth w ~

Rename...
Footing
''on top of each other. —— A\ Type Ferometers
i Stacked ﬁﬁ}]} ~ | Hg Edit Type Parameter Value =
Sy
| G Nt - Construction &
1. Wall > Stack Walls > Edit T
’ a ac alls ! ype Edit Assembly
. . Family: Stacked wall
2. At Type Properties, Edit Structure A Typ Cladding w Plinth w Footing
Offsat: Core Centerline v Sample Height:  6000.0
3. Insert or Delete new Sub walls and assign
the placement accordingly THpes
4. Set the Height and Offset I Lt L —
4 3 |Fnd 440 Tren 700.0 127.5 0.0 0.0 O
4 |Fnd - 750-F 1300.0 127.5 0.0 0.0 O
BASE
‘.’a&le Insert Delete Up Down

The Education and Research arm of the Building and Construction Authority



BCA ACADEMY

Spllt Face & Paint

s Modify | Walls

[} X I‘:._Cope - & |z & Dhs‘ D' | 5 dfe Q - — [%] [C\Cﬁ E{ A _fD =
[E]O”qutv‘?.z@o-‘:' k. ﬂnu.ﬂu‘,'ﬁ ) n =
Modify Il 2 b ‘_g.’ o~ %T ". ¥ f . ?;’D Edit ¢ Wall Attach Detach
= v B B oin - £ K & Q I =2 = x| & & @ | profile - | Opening Top/Base Top/Base
Select v | Properties | Clipboard Geometry Modify View Measure Create Mode ’ Modify Wall

SF or Modify > Spilt Face &)

Paint : Apply a material to the face of an
- elemen’r

Ceiling Tile  Ceiling Tile
20024300 600 x 600

Li
—cnerry . Cladding,
bed

PT or Modify > Paint 25 2 | o |
Search Q
|- T T T T T T T T T T s T T s s s s e s s === b Project Materials: All v> =
' Split Face : Divide the face of an | g v Ram
1 element such as wall, floor, column into ! H ! m
1 . . . . -
| regions for the application of different 1 \ o o [ H
| mo-l-erlols | | Horiz.tterm  Sold..urse  |Soldi...rse,
|
| |
I 1
| 1
|
|

1. Select Split Face (SF), click on the surface, draw the splitting
line and close the edit mode

2. Select Paint (PT), choose material and click on the surface
to apply
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Curtain Wall

Architecture

N E 1 % K Area - @ zle 2 wal ) Show
M BE
: i fy Vertical [7 Ref Plane
Modify| Wall Door Window Component  Column Roof Ceiling Floor |CurtainfCurtain Mullion Ralllng Ramp Stair | Model Model Model || Room  Room Tag By Shaft . gﬂ Grid Set
T v v System| Grid v Text Line Group Separator Room ~ [ Tag Area ~ Face J Dormer [ER viewer
Select | Build ' Circulation | Model | Room & Area « | Opening | Datum | Work Plane |

Architecture Tab > Wall ——

Curtain Wall 1 : has no grids or mullions. There are no rules ,@ :|

Exterior Glazing : has preset grids. The grid rules can be
' changed if the setting is nof suitable
! Storefront : has preset grids and mullions. The grid and mullion
. rules can be changed if the setftings are not suitable

1
I
. associated with this wall type - provides the most flexibility
1
I
|

1. Create new curtain walls

2. Adjust the placement and orientatfion of curtain walls

I

3. Define curtain wall type properties to automatically place \ \

curtain grids and mullions |
i.\

4. Adjust panels / mullions to suit design needs \ \\\

]
.
/
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Architecture

Ol E g U /48688

% % @ & @ @Ik [Cb] I:% [% (] Area - F‘E;? g]g%wml @E,-Show

B[y Vertical I7 Ref Plane
Modify| Wall Door Window Component  Column Rogf Ceiling | Floor |Curtain|Curtain Mullion | Railing Ramp Stair  Model Model Model | Room Room Tag i By  Shaft If gﬁ Grid Set 7
T v v v T Grid v v Text Line Group Separator Room Tag Area ~ Face J Dormer [ER viewer
Select ~ | Build | Circulation | Model | Room & Area « | Opening | Datum | Waork Plane

Architecture Tab > Ceiling

| Modify | Place Ceiling

1. Go to Floor Plan / Ceiling Plan @ @

Automatic| Sketch” @ ' O g
2. Create ceiling by Automatic Ceiling or by Ceiling | Citingh \ \\
Sketch Ceiling ceililg U~ _ \\

o

| i Jif“”e“fe-" X

@ ‘ : D 1
Compound Ceiling
| | Plain
| |
@*****‘f*****j‘"’* Ceilings v | £ Edit Type
i i i onstraints A
@ ” | | i Level Level 2

Height Offset Fro...: 25000
Room Bounding
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Railing Ramp| Stair

I FEE W

Roof Ceiling Floor [Curtain|Curtain Mullion
System| Grid

Build |

OO E g

Modify Wall Door Window Component Column

Select | Circulation

Architecture Tab > Stair

' . Stair by Component : add a stair o the building model
| by creating a common run and landing

|
 Stair by Sketch : add a stair in a building by sketch

e e o o o o e o e e e e e e e e e e e Em e Em e Em R R Em e Em e Em Em Em e Em e Em e e e e

1. Create stairs by sketching run lines

2. Flip a stair direction and move a stair into place

3. Create stairs with multiple runs and complex layouts
(for example, L-shaped,
U-shaped, and curved stairs)

4. Adjust or remove railings as desired

I:% [% EArea'

I\ @

odel Model Model || Room Room Tag
Text Line Group Separator Room ~ [ Tag Area -
Model | Room & Area « |

@ Stair by Component
’% Stair by Sketch

Y =z r: = Wall B Show
M 3 "I o
Vertical Ref PI
By Shaft g Vertica gﬂGrid et 4P Ref Plane
Face 4 Dormer @ Viewer
Opening | Datum | Waork Plane

}

Vs

3080.0

=By Components

=By Sketch
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Railing

BCA ACADEMY

Architecture

S E 4

L

Modify

I FEE W

Door Window Component Column Roof Ceiling Floor |Curtain

Wall
M v M M System

Select ~ | Build

Architecture Tab > Railing

Open the Railing tool

Specify offset and sketch the railing
boundary

Edit Rail Structure (horizontal)
Edit Baluster Placement (vertical)

Specify Height and Type for Top Rail

o9 Al

Ll

PR

E,- Show

- zIz = Wall

™ == . o
i i Vertical Ref Plane
Curtain Mullion | Railing |Ramp Stair | Model Model Model | Room Room Tag By  Shaft f Sﬁ Grid set
Grid M M Text Line Group Separator Room Tag Area ~ Face 4 Dormer @ Viewer
Circulation | Model | Room & Area « | Opening | Datum | Waork Plane
Modify | Create Railing Pa“
Type Parameters : ! l
| =
Parameter _Nalue | x D @ Ly @ - (
‘.,4 {\. [..
Railing Height 1100.9 L /: . . '(t§ Bt
Rail Structure (Non-Continuous) Z; v Edit... « —)
. Mode Draw ’
Use Landing HeightAdjustment No
Landing Height Adjustmient 0.0
Angled Joins Add Vertical/Horizontal Segment
Tangent Jains Extend Rails to Meet Family: Railing
Rail.Connections Trim Type: 1100mm Balcony
Rails
Height 1100.0 Name Height Offset Profile Material
Type Rectangular - 50x50mm - -
1 |Top Rail 90[24 0.0 Square Handrail : 20m <By Category>
2 [Mid Rail 500.0 0.0 Square Handrail : 20m  <By Category>
3 |Bottom Rail (200.0 0.0 Square Handrail : 20m  <By Category>
I -
Insert | | Duplicate | | Delete up
Family: Railing Type: 1100mm Balcony
Main pattern
. Base Top |Dist. from
Name Baluster Family Base offset Top o7z | s Offset
1 |Pattern sta:N/A N/A N/A NJA N/AIN/A N/A
2 |Regular b :Baluster - Square : Host 0.0 Top Rail 0.0 300.0 0.0
3 |Pattern en:N/A N/A N/A NJA N/A 0.0 N/A
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Roof

Architecture

S S0 E @ @g@ma BoO AR KME K E~ s~ .. @

Modify| Wall Door Window Component  Column eiling Floor |Curtain|Curtain Mullion | Railing Ramp Stair | Model Model Model || Room Room Tag By  Shaft hl& Vertical Sﬁ Grid Set E; Ref Plane
T v v T System| Grid v v Text Line Group Separator Room Tag Area ~ Face [~ Dormer [ER viewer
Select v| Buil | Circulation | Model | Room & Area « | Opening | Datum | Waork Plane
Architecture Tab > Roof | | | = |
e, [ ————"
Roof | Ceiling _FiSe ‘ | ‘ ‘
. : IP Rogf by'footprint ‘ | ‘ ‘
1. At the Roof Level, select Roof: by Footprint | 1 [ i | Wwval S
x: Roofiby Extrusion = | i | ! ‘
2. Set Overhang val » | | | | |
Se O erha g aive @RoofbyFace ‘ ' ' ‘ ‘
. ' | A boalt
3. Create Roof by sketching the boundary N Root: o B | ‘ |
4. Ensure that the lines are enclosed in a loop, close Q/“Rm”ascia ‘ | ‘ ‘
the edit mode by selecting the green tick =Rooefs N7 root e e ) b
created M | |
| I =N I | |

4 Modify | Create Roof Footprint [ Lad=
,':\ AN %
x I\, Boundary Line '/ 206 @

Definesslope | Overhang:| 100.00 [ Extend to wall core

OO A,
2 ¢ @] Slope Arrow > S {[{ .? .
Mode Draw
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VU0 E g (|FecEEE BOoD Al RE KB~ fuiw £ 5o
Modify| Wall Door Window Component  Column Roof | Ceiling Floor |Curtain|Curtain Mullion | Railing Ramp Stair  Model Model Model | Room Room Tag By  Shaft v Vertica Sﬁ Grid Set & et Flane
T v v v T System| Grid v v Text Line Group Separator Room Tag Area ~ Face [~ Dormer Viewer
Selectv| BUITO | Circulation | Model | Room & Area « | Opening | Datum | Work Plane
| Modify | Roofs |
5. Click on the created Roof > Edit Footprint ~ - ===
6. Select one side of roof and change the slope value ‘
/. Select the other two side of the roof and uncheck - ‘ A
Defines Roof Slopes =]
|
/ ‘
Properties b4 ———T———-
- |
<Sketch> (2) / v‘ Edit Type = _ _ ,L _
Constraints B3 ‘ L
7 Defines Roof Slope !
Offset From Roof Base 0.0
Dimensions B3
Slope 30.00°
Length 7800.0
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Roof

OO E g [(FeEEH

Select ~ | Buifd

8. Change Roof height
9. Change Roof Rafter Cut Option

Modify Wall Door Window Component Column Roof |Ceiling Floor |Curtain|Curtain Mullion | Railing Ramp
M System| Grid v

| Circulation

10. Change Roof properties (Edit type >

duplicate..)

11. Connect Walls to Roof
a. Select the Walls to connect

b. Click Modify > Attach Top / Base
c. Select the Roof to connect

BCA

ACADEMY

b &|F
M =
Wall Attach
Opening] Top/Base
Modify Wall

4
Detach
op/Base

] & Area - @ zle 2 wal ' Show
HE BoS ALR EE K REE .
Vertical Ref Plane
Stair | Model Model Model || Room Room Tag By  Shaft f Sﬁ Grid set 7
M Text Line Group Separator Room Tag Area ~ Face 4 Dormer @ Viewer
| Model | Room & Area « | Opening | Datum | Waork Plane
Properties X
Basic Roof
E Pitched - Warm - -
Industrial
9 Roofs (1) ~ | H@ Edit Type
Constraints g
Tonsracaon
Rafter Cut Plumb Cut| j
Typé Properties X Fascia Depth
10 I Maximum Ridg... iTwo Cut - Plumb
Family: |Sy5tem Family: Basic Roof V| Load... i . [Two Cut - Square '

Type: |Pi‘tched - Warm - Industrial b Duplicate...
Rename...

Type Parameters

| Parameter | Value | :| 4
Structure Edit...
Default Thickn%, 515.00
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Two Cut- Plumb

Two Cut- Square
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